Automatically elevating UAC in Windows 7 joined in a Domain Account

Until I’m connected to my workplace domain network everything worked fine for me in Windows 7 with Admin user. I faced no problem in running Visual studio and executing batch files. For the things which I want to run/open/execute with Administrator privilege I was able to permanently set it through “Run this program as an Administrator” privilege level in the “Properties” dialog. But once joined into the domain account, this option gets disabled.

For the past 10 days I was annoyed on clicking the “Yes” button on Windows 7’s UAC whenever I open Visual Studio. The simpler solution for this is to disable the UAC but that does not solve the problem since after that Visual Studio will be running in normal mode which is a restricted one and not in the Admin mode, which gives the full control from virtual directory creation, IIS configuration etc.

For those who are using Windows 7 in the development environment connected with a Domain Account, here is a handy tip to overcome the UAC annoyance.”You must be an administrative user to perform the following steps”

Step 1: Click start Button and type gpedit.msc on the search box.

Windows 7 Start Menu Search

Step 2: In the Group Policy Editor window navigate to Computer Configuration -> Windows Settings -> Security Settings -> Security Options.

Group Policy Editor

Step 3: Configure the following setting.

User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode – Set its value to Elevate without prompting.

User Account Control: Detect application installations and prompt for elevation – Set its value to Disabled.

User Account Control: Only elevate UIAccess applications that are installed in secure locations – Set its value to Disabled.

User Account Control: Run all administrators in Admin Approval Mode – Set its value to Disabled.

Windows 7 Start Menu Search

Group Policy Editor

Step 4: Restart the computer. That’s it you are done.

cheers,

yenkay